CEL: P0171 (System Too Lean) - Club RSX Message Board
Go Back   Club RSX Message Board > GENERAL > Problems & Solutions
Use the same user name on Club RSX, Club EP3, and Club ILX!

Reply
 
Thread Tools
Old 09-21-2009, 12:20 PM   #1
Adam_T
Senior n00b
 
Join Date: Jun 2007
Location: Charlotte, NC
Posts: 1,627
iTrader: (26)
CEL: P0171 (System Too Lean)

Okay so I just brought my car back to stock. I had BC Stg2 cams, 410cc injectors, CAI, DC Race Header and a 2.5 inch catback exhaust...

Now I have stock cams, stock injectors, stock header/cat/exhaust, stock ECU (had kpro)...

Okay so now that everything is stock (except the CAI, I still have a fujitia CAI installed) I get the engine code P0171 which says system too lean.


What do you guys think? I checked all the tubing coming from the CAI into the engine and everything is good there. The injectors I ordered were used from a guy on the forums....he says they only had 30k miles but maybe they got clogged a bit during shipment?


Anywho....being stock, I don't know too much about the stock parts hahahaha. So I have no idea what could be doing this. Acura wants to charge me $240 just to find out what it is and I basically said fuckkkkk thatttt.

Help! Give me some known problems for this and some solutions. Thanks a lot.
Adam_T is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-21-2009, 08:42 PM   #2
Adam_T
Senior n00b
 
Join Date: Jun 2007
Location: Charlotte, NC
Posts: 1,627
iTrader: (26)
ttt
Adam_T is offline   Reply With Quote
Old 09-22-2009, 11:05 AM   #3
Adam_T
Senior n00b
 
Join Date: Jun 2007
Location: Charlotte, NC
Posts: 1,627
iTrader: (26)
ttt
Adam_T is offline   Reply With Quote
Old 09-22-2009, 01:28 PM   #4
rensoyka
Breast inspector by appt.
 
rensoyka's Avatar
 
Join Date: Aug 2005
Location: The Continuum
Posts: 9,225
iTrader: (1)
if there are no other CEL codes then the likely problem is either low fuel pressure, malfunctioning injectors, improper valve clearances, faulty A/F sensor, faulty evap canister purge valve.
__________________
'06 black type-s.
rensoyka is offline   Reply With Quote
Old 09-23-2009, 04:14 PM   #5
iKhaotic
Senior Member
 
iKhaotic's Avatar
 
Join Date: Sep 2008
Location: Orlando, FL
Posts: 721
iTrader: (1)
i also have this code. how will this affect the car and how is it fixed?
__________________
2005 MM-S
A-Spec \\\ Skunk2 \\\ Kenwood \\\ Retro-Solutions
iKhaotic is offline   Reply With Quote
Old 09-23-2009, 08:13 PM   #6
Adam_T
Senior n00b
 
Join Date: Jun 2007
Location: Charlotte, NC
Posts: 1,627
iTrader: (26)
Quote:
Originally Posted by rensoyka View Post
if there are no other CEL codes then the likely problem is either low fuel pressure, malfunctioning injectors, improper valve clearances, faulty A/F sensor, faulty evap canister purge valve.

That's a lot of options....

I think it might be the injectors seeing how I just put the new (aka used stock injectors) in the other day and that is the day the code went on. I wonder how I can get them cleaned though....:-/
Adam_T is offline   Reply With Quote
Old 09-23-2009, 08:25 PM   #7
Jay
likes to troubleshoot
 
Join Date: Dec 2001
Location: Arroyo Grande, CA
Posts: 2,400
iTrader: (0)
Chevron Techron will clean them (if they're dirty).
__________________
base/auto Comptech air filter
Jay is offline   Reply With Quote
Old 09-23-2009, 08:38 PM   #8
Adam_T
Senior n00b
 
Join Date: Jun 2007
Location: Charlotte, NC
Posts: 1,627
iTrader: (26)
Im wondering...should I just run it through my gas tank? Or should I put all 4 of my injectors in a plastic zip-lock...pour a bit of the Chevron Techron in there (enough to cover all 4) and then submerse the bag in a Ultrasonic Cleaner (I do have access to one of these so...)

Anywho...
Adam_T is offline   Reply With Quote
Old 09-24-2009, 04:49 PM   #9
Jay
likes to troubleshoot
 
Join Date: Dec 2001
Location: Arroyo Grande, CA
Posts: 2,400
iTrader: (0)
If you're ambitious, plan B would be the quickest. Plan A is the easiest and also effective, but takes longer.
__________________
base/auto Comptech air filter
Jay is offline   Reply With Quote
Old 09-26-2009, 04:32 PM   #10
Adam_T
Senior n00b
 
Join Date: Jun 2007
Location: Charlotte, NC
Posts: 1,627
iTrader: (26)
So far so good with the Chevron Techron...CEL light still on of course (only have driven about 20 miles since I added it, and haven't reset the light yet) but there is no hesitation yet when hitting higher RPMS like there used to be.

Ill update as soon as I see something new.
Adam_T is offline   Reply With Quote
Old 09-26-2009, 05:41 PM   #11
iKhaotic
Senior Member
 
iKhaotic's Avatar
 
Join Date: Sep 2008
Location: Orlando, FL
Posts: 721
iTrader: (1)
Quote:
Originally Posted by Jay View Post
Chevron Techron will clean them (if they're dirty).
Chevron Techron = Texaco Techron?

they should be the same right? since they're the same company and all.....?

if so, i've been using Texaco Techron 85% of the time for the past 10k miles and when i pulled the codes a few days ago, the "system too lean" code is still there...
__________________
2005 MM-S
A-Spec \\\ Skunk2 \\\ Kenwood \\\ Retro-Solutions
iKhaotic is offline   Reply With Quote
Old 01-22-2010, 07:37 AM   #12
Adam_T
Senior n00b
 
Join Date: Jun 2007
Location: Charlotte, NC
Posts: 1,627
iTrader: (26)
This code still isn't off my car yet....after these long months. I have had:

-both o2 sensors replaced under warranty b/c that's what acura said it was
-Valve-lash done to make sure clearances were good
-Timing chain adjustment (acura then said this was the problem and they did this)

engine light always came back on the next day. :-) YAY! Could it still possibly be the fuel injectors? I've ran 3 containers of Cheron Techtron since I've had this code.

what else could this be?! Basically all of the options that the code throws up have been "fixed".
Adam_T is offline   Reply With Quote
Old 02-28-2010, 01:54 AM   #13
bsivoljr
Dafkup
 
bsivoljr's Avatar
 
Join Date: Oct 2009
Location: WHERE EVERYTHING IS BIG
Posts: 1,997
iTrader: (6)
Fix the exhaust
__________________
Had a K long before I bought the RSX...
bsivoljr is offline   Reply With Quote
Old 02-28-2010, 02:17 AM   #14
guswaym
Special Olympics Winner
 
guswaym's Avatar
 
Join Date: May 2008
Location: Regina, Sask.
Posts: 3,032
iTrader: (1)
what sensor throws this CEL?
__________________
[b]
2011 Mitsubishi Evolution GSR
2010 Honda Civic SI Sedan TOTAL LOSS
2003 Acura RSX Type-S SOLD
guswaym is offline   Reply With Quote
Old 03-01-2010, 11:02 AM   #15
bsivoljr
Dafkup
 
bsivoljr's Avatar
 
Join Date: Oct 2009
Location: WHERE EVERYTHING IS BIG
Posts: 1,997
iTrader: (6)
Quote:
Originally Posted by guswaym View Post
what sensor throws this cel?
o2
__________________
Had a K long before I bought the RSX...
bsivoljr is offline   Reply With Quote
Old 03-01-2010, 01:02 PM   #16
mtxjohn
02 blue type-s
 
mtxjohn's Avatar
 
Join Date: Feb 2006
Location: MN
Posts: 312
iTrader: (1)
what sensor p0171

I got that code, it was the primary o2 sensor. I also threw the code P0135. Im all stock-105k when this happened. Replaced primary o2 sensor and reset codes and all fixed.
__________________
2002 RSX-S (196,000 miles ) WD-40 stands for Water Displacement. It is NOT a proper lubricant. In fact, if you try to use it as such it will wash away (dissolve) any actual lubricant that was there to start with.
I'm the top RSX on Fuelly!!!
http://www.fuelly.com/driver/mtxjohn/rsx
An armed man in a citizen, an unarmed man is a peasant.

Last edited by mtxjohn; 03-01-2010 at 01:49 PM.
mtxjohn is offline   Reply With Quote
Old 01-08-2012, 01:31 PM   #17
nuno
gotta pay to play..
 
nuno's Avatar
 
Join Date: Mar 2011
Location: Tampa, FL
Posts: 3,157
iTrader: (66)
Bringing this shitt up from the grave... I'm having the same code and it chokes on high rpms and vtec does not pop =( help
__________________
follow me on IG @thisisnuno

2014 update show off link:
http://forums.clubrsx.com/showthread.php?t=938074
nuno is offline   Reply With Quote
Old 01-09-2012, 09:33 AM   #18
nuno
gotta pay to play..
 
nuno's Avatar
 
Join Date: Mar 2011
Location: Tampa, FL
Posts: 3,157
iTrader: (66)
??
__________________
follow me on IG @thisisnuno

2014 update show off link:
http://forums.clubrsx.com/showthread.php?t=938074
nuno is offline   Reply With Quote
Old 01-09-2012, 09:12 PM   #19
nuno
gotta pay to play..
 
nuno's Avatar
 
Join Date: Mar 2011
Location: Tampa, FL
Posts: 3,157
iTrader: (66)
no one can help?
__________________
follow me on IG @thisisnuno

2014 update show off link:
http://forums.clubrsx.com/showthread.php?t=938074
nuno is offline   Reply With Quote
Old 01-11-2012, 12:25 AM   #20
bsivoljr
Dafkup
 
bsivoljr's Avatar
 
Join Date: Oct 2009
Location: WHERE EVERYTHING IS BIG
Posts: 1,997
iTrader: (6)
Quote:
Originally Posted by nuno View Post
no one can help?
Why don't you help yourself? Do you have any codes? Have you checked ANYTHING?
__________________
Had a K long before I bought the RSX...
bsivoljr is offline   Reply With Quote
Old 01-11-2012, 12:49 AM   #21
nuno
gotta pay to play..
 
nuno's Avatar
 
Join Date: Mar 2011
Location: Tampa, FL
Posts: 3,157
iTrader: (66)
http://forums.clubrsx.com/showthread.php?t=806068
__________________
follow me on IG @thisisnuno

2014 update show off link:
http://forums.clubrsx.com/showthread.php?t=938074
nuno is offline   Reply With Quote
Old 01-11-2012, 12:59 AM   #22
bsivoljr
Dafkup
 
bsivoljr's Avatar
 
Join Date: Oct 2009
Location: WHERE EVERYTHING IS BIG
Posts: 1,997
iTrader: (6)
Quote:
Originally Posted by nuno View Post
Replied
__________________
Had a K long before I bought the RSX...
bsivoljr is offline   Reply With Quote
Reply

Bookmarks

Tags
cel, lean, p0171, system

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:32 PM.


Privacy Policy  |  Disclaimer Notice
Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2001-2012, Club RSX, Inc. All rights reserved worldwide.
This website is owned and operated by Club RSX, Inc.
Club RSX, Club EP3, and Club ILX are not affiliated with American Honda Motor Co., Inc.