P0325 Knock Sensor Circuit Malfunction - Club RSX Message Board
Go Back   Club RSX Message Board > GENERAL > Problems & Solutions
Use the same user name on Club RSX, Club EP3, and Club ILX!

Reply
 
Thread Tools
Old 12-25-2010, 03:35 PM   #1
DocStrange7
Member
 
DocStrange7's Avatar
 
Join Date: Sep 2010
Location: Pasadena
Posts: 54
iTrader: (0)
P0325 Knock Sensor Circuit Malfunction

Took my RSX to pep boys. Checked the codes. this is what is causing my check engine light to go on. I'm still driving the car. Don't feel any problems. PepB's Tech told me that the only thing with this, is that it will not pass smog check> this true? Will I cause harm for my car if I keep driving?
DocStrange7 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-25-2010, 04:16 PM   #2
rsxmike22
Member
 
rsxmike22's Avatar
 
Join Date: Aug 2010
Posts: 164
iTrader: (1)
Change the knock sensor, runs in limp mode and car might have other damage.
rsxmike22 is offline   Reply With Quote
Old 12-25-2010, 05:47 PM   #3
LastTypeS
Master Member
 
LastTypeS's Avatar
 
Join Date: Feb 2007
Location: PSL, FL
Posts: 1,683
iTrader: (2)
The knock sensor connector could be loose or completely unplugged. Happend to me after I took my tranny out I forgot to connect it. Get under the car and reach your hand up: it's under the intake manifold and it's bright green. I would check this first before you start spending $$
__________________
219/161
Set up for autoX
335whp on spray for fun

www.facebook.com/FastestOfFlorida
Getting set up for part 2!
LastTypeS is offline   Reply With Quote
Old 12-25-2010, 07:02 PM   #4
DocStrange7
Member
 
DocStrange7's Avatar
 
Join Date: Sep 2010
Location: Pasadena
Posts: 54
iTrader: (0)
Yeah i'll check that out. My clutch was recently replaced, maybe the sensor might of gotten unplugged. Thanks for the heads up
DocStrange7 is offline   Reply With Quote
Old 12-25-2010, 07:16 PM   #5
LastTypeS
Master Member
 
LastTypeS's Avatar
 
Join Date: Feb 2007
Location: PSL, FL
Posts: 1,683
iTrader: (2)
Lol dang... exact same scenario.. I hope it's the same problem I had good luck :
__________________
219/161
Set up for autoX
335whp on spray for fun

www.facebook.com/FastestOfFlorida
Getting set up for part 2!
LastTypeS is offline   Reply With Quote
Old 12-30-2010, 02:24 AM   #6
DocStrange7
Member
 
DocStrange7's Avatar
 
Join Date: Sep 2010
Location: Pasadena
Posts: 54
iTrader: (0)
Damn! Still haven't fixed my knock sensor. Too lazy and broke. But i'm thinking to replace it soon. Didn't know much bout it but I found some info .

The heart of your vehicle's engine management system – that's what your car's knock sensors are. Knock sensors enable your vehicle to achieve the maximum combination of fuel/air mixture and timing to increase power and efficiency generated.

Knock sensors also protect car parts from the damaging effects of engine knock. When a knock sensor is bad, it can't regulate the engine properly. The car vibrates and it sounds like there is something banging up against the car's cylinder. The knocking action can destroy the pistons, rods, valves, gaskets and plugs.

Read more: What Is a Knock Sensor? | eHow.com http://www.ehow.com/facts_5503579_kn...#ixzz19qfrrhqn

Last edited by DocStrange7; 01-01-2011 at 10:26 PM. Reason: Better info
DocStrange7 is offline   Reply With Quote
Old 12-30-2010, 02:26 AM   #7
DocStrange7
Member
 
DocStrange7's Avatar
 
Join Date: Sep 2010
Location: Pasadena
Posts: 54
iTrader: (0)
Cookies!

Last edited by DocStrange7; 01-01-2011 at 10:09 PM. Reason: none
DocStrange7 is offline   Reply With Quote
Old 12-30-2010, 02:27 AM   #8
DocStrange7
Member
 
DocStrange7's Avatar
 
Join Date: Sep 2010
Location: Pasadena
Posts: 54
iTrader: (0)
It's located underneath the intake manifold behind a black bracket. It's easiest to remove the the whole manifold but if it's not an option just remove the black brackets and use a open wrench to remove it. It shouldnt be too hard to twist and take it off--

thanks avinad for the info.

Last edited by DocStrange7; 01-01-2011 at 10:12 PM. Reason: Helpful info
DocStrange7 is offline   Reply With Quote
Old 02-13-2013, 10:21 AM   #9
svaillan
GT30R > Traction
 
svaillan's Avatar
 
Join Date: Apr 2006
Location: Mota...Sicily..Yep Italy
Posts: 3,831
iTrader: (0)
I'm having this same problem, I have replaced the sensor and the car runs fine up to vetch then I get a knock sensor malfunction. I do not have the car tuned yet fir the new engine so I'm thinking its advance and the change in displacement and compression but I don't really want to go get a tune if something else might be wrong...anyone have any experience with this???
__________________
Workout Crew, Wind surfing crew #1 Boost Slut krew#12...My Name is Steve

[SIGPIC][/SIGPIC]
I'm so stock my valves tickFull-Race stage 2gt RSX 449WHP 313TQ @ 14 psi on 91
semper fidelis tyranosaurus Rex
svaillan is offline   Reply With Quote
Old 02-13-2013, 10:38 AM   #10
2010 admin
Administrator
 
Join Date: Dec 1969
Posts: 2,759
iTrader: (27)
2010 admin has disabled reputation
Quote:
Originally Posted by svaillan View Post
I'm having this same problem, I have replaced the sensor and the car runs fine up to vetch then I get a knock sensor malfunction. I do not have the car tuned yet fir the new engine so I'm thinking its advance and the change in displacement and compression but I don't really want to go get a tune if something else might be wrong...anyone have any experience with this???
Actual malfunction code or just the flashing MIL light?
2010 admin is offline   Reply With Quote
Old 02-13-2013, 11:14 AM   #11
svaillan
GT30R > Traction
 
svaillan's Avatar
 
Join Date: Apr 2006
Location: Mota...Sicily..Yep Italy
Posts: 3,831
iTrader: (0)
It's not a fleshing cel like you get with a knock, it's a cel that stays on then the code comes up and the car goes into limp mode. If I clear the code and repeat the same thing happens.
__________________
Workout Crew, Wind surfing crew #1 Boost Slut krew#12...My Name is Steve

[SIGPIC][/SIGPIC]
I'm so stock my valves tickFull-Race stage 2gt RSX 449WHP 313TQ @ 14 psi on 91
semper fidelis tyranosaurus Rex
svaillan is offline   Reply With Quote
Old 02-13-2013, 11:21 AM   #12
2010 admin
Administrator
 
Join Date: Dec 1969
Posts: 2,759
iTrader: (27)
2010 admin has disabled reputation
Wow, how weird.
2010 admin is offline   Reply With Quote
Old 02-13-2013, 11:28 AM   #13
svaillan
GT30R > Traction
 
svaillan's Avatar
 
Join Date: Apr 2006
Location: Mota...Sicily..Yep Italy
Posts: 3,831
iTrader: (0)
Quote:
Originally Posted by 2010 admin View Post
Wow, how weird.
I know, I blew the last engine and rebuilt it with a CRSX turbo short block and other upgrades; so I figured that the rod blowing out the side of the old engine might have fouled the old sensor...and now with the change in A/F ignition and compression might have the fuel tables so screwed up that as soon as the car switches to high speed cams the new sensor might be sending the car right into limp mode.
__________________
Workout Crew, Wind surfing crew #1 Boost Slut krew#12...My Name is Steve

[SIGPIC][/SIGPIC]
I'm so stock my valves tickFull-Race stage 2gt RSX 449WHP 313TQ @ 14 psi on 91
semper fidelis tyranosaurus Rex
svaillan is offline   Reply With Quote
Old 02-13-2013, 11:41 AM   #14
2010 admin
Administrator
 
Join Date: Dec 1969
Posts: 2,759
iTrader: (27)
2010 admin has disabled reputation
Well, you could always disable the knock sensor. That's how mine is. You need to get the car tuned on a actual dyno in order to do that, though.
2010 admin is offline   Reply With Quote
Old 02-13-2013, 12:35 PM   #15
BattleshipDC5
New Member
 
Join Date: Feb 2013
Posts: 27
iTrader: (0)
Those things are fragile.. If your clutch recently got replace chances are it broke off or maybe a brittal wire is getting a bad connection/broke
BattleshipDC5 is offline   Reply With Quote
Old 11-04-2013, 07:24 PM   #16
betsonm08
Member
 
betsonm08's Avatar
 
Join Date: Dec 2011
Location: Dallas, TX
Posts: 48
iTrader: (1)
I'm having issues with my knock sensor as well. I replaced it a couple of days ago and the cel went away for a little while and came right back on. It's a brand new knock sensor and I'm almost certain it's not the knock sensor, my car is also idling at 1400 rpm instead of 800. I have kpro, CAI, plm race header and tanabe catback. Do I need to reset the code from the ECU or anything? I took the negative off the battery for about 15 mins and I thought that would reset everything but I guess not. Is there anything else I could do other than trying a different knock sensor?
betsonm08 is offline   Reply With Quote
Reply

Bookmarks

Tags
circuit, knock, malfunction, p0325, sensor

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:30 AM.


Privacy Policy  |  Disclaimer Notice
Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2001-2012, Club RSX, Inc. All rights reserved worldwide.
This website is owned and operated by Club RSX, Inc.
Club RSX, Club EP3, and Club ILX are not affiliated with American Honda Motor Co., Inc.